Problems with Multitap.

BIOS, Controllers, Memory Cards, Serial I/O, Parallel I/O, etc.
Post Reply
User avatar
MihaiGamerXD
Active PSXDEV User
Active PSXDEV User
Posts: 39
Joined: March 9th, 2019, 7:10 am
I am a: Programmer
PlayStation Model: SCPH-1001
Want to Find: Codes
Looking to: Examples

Problems with Multitap.

Post by MihaiGamerXD » January 26th, 2021, 2:29 am

Hi! I have a problem with Multitap controls. The only thing I'm trying to fix is the sprite movement: When I move the sprite with digital/analog controls, the sprite sometimes it doesn't stop moving, but after some moments it stops moving. I don't think there's a way to fix that problem because it may be a bug from the Psy-Q SDK, or I don't know exactly. I may give you the ISO game, so I hope you understand what's the problem:
https://www.dropbox.com/s/8erc3xu3uzy7k ... d.zip?dl=0
I'm actually testing in an emulator. Thank you in advance!

User avatar
Shadow
Admin / PSXDEV
Admin / PSXDEV
Posts: 2471
Joined: December 31st, 2012, 5:37 pm
PlayStation Model: H2000/5502

Re: Problems with Multitap.

Post by Shadow » January 26th, 2021, 3:06 pm

There isn't a problem with the multitap library. The problem may be something in your code but my guess is the emulator is doing something wrong. Don't use emulators for testing. They are not accurate and none really emulated the multitap protocol correctly.

You said it happens when you switch controller modes. You should be stopping your sprites movement when a controller change is detected since the library still keeps the old controller values locked for a few VSync's until it detects a controller has been removed and then it resets the buffers.
Development Console: SCPH-5502 with 8MB RAM, MM3 Modchip, PAL 60 Colour Modification (for NTSC), PSIO Switch Board, DB-9 breakout headers for both RGB and Serial output and an Xplorer with CAETLA 0.34.

PlayStation Development PC: Windows 98 SE, Pentium 3 at 400MHz, 128MB SDRAM, DTL-H2000, DTL-H2010, DTL-H201A, DTL-S2020 (with 4GB SCSI-2 HDD), 21" Sony G420, CD-R burner, 3.25" and 5.25" Floppy Diskette Drives, ZIP 100 Diskette Drive and an IBM Model M keyboard.

User avatar
MihaiGamerXD
Active PSXDEV User
Active PSXDEV User
Posts: 39
Joined: March 9th, 2019, 7:10 am
I am a: Programmer
PlayStation Model: SCPH-1001
Want to Find: Codes
Looking to: Examples

Re: Problems with Multitap.

Post by MihaiGamerXD » January 26th, 2021, 9:20 pm

Shadow wrote:
January 26th, 2021, 3:06 pm
There isn't a problem with the multitap library. The problem may be something in your code but my guess is the emulator is doing something wrong. Don't use emulators for testing. They are not accurate and none really emulated the multitap protocol correctly.
That's what I was thinking that emulator maybe is not perfect enough, you're right! So I have to test in real console for some reason.
Shadow wrote:
January 26th, 2021, 3:06 pm
You said it happens when you switch controller modes. You should be stopping your sprites movement when a controller change is detected since the library still keeps the old controller values locked for a few VSync's until it detects a controller has been removed and then it resets the buffers.
Did I say it happens when I switch controler modes? I can't realize... And should I have to detect when controller changes itself, or should I use VSync's? Maybe I should test in real console as a simple method ;) but first I need to get a multitap device + 2 more controllers cuz I don't have them. Also thank you for the information. :)

EDIT: I got the Multitap device, I tested in real console, it worked better than in emulator. So this means I have to test in real console. Thank you so much for the help!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest