getting MIDIs to play on psx

Audio and Music (Sound Processing Unit) based area of development, including VAB, XA, etc
Post Reply
Yagotzirck
Serious PSXDEV User
Serious PSXDEV User
Posts: 82
Joined: July 17th, 2013, 2:37 am

getting MIDIs to play on psx

Post by Yagotzirck » December 1st, 2013, 12:31 am

I'm experimenting a little with SEQ format, trying to play a few midis... converting them is a piece of cake(SMF2SEQ), the troublesome part is creating a proper .VAB sound bank for the seq to be played properly. Does anyone have a clue about this?

User avatar
Shadow
Admin / PSXDEV
Admin / PSXDEV
Posts: 2233
Joined: December 31st, 2012, 5:37 pm
PlayStation Model: H2000/5502

Re: getting MIDIs to play on psx

Post by Shadow » December 1st, 2013, 1:31 am

Try using VABTOOL.
Development Console: SCPH-5502 with 8MB RAM, MM3 Modchip, PAL 60 Colour Modification (for NTSC), DB-9 breakout headers for both RGB and Serial output and an Xplorer with CAETLA 0.34.

Development Computer: Windows 98, Pentium 3 [400MHz], 128MB SDRAM, DTL-H2000, DTL-H201A, 21" Sony Trinitron CRT, CD-ROM burner, 3.25" and 5.25" Floppy Diskette Drives and a ZIP 100 Diskette Drive.

Yagotzirck
Serious PSXDEV User
Serious PSXDEV User
Posts: 82
Joined: July 17th, 2013, 2:37 am

Re: getting MIDIs to play on psx

Post by Yagotzirck » December 1st, 2013, 5:13 am

I've tried it already but didn't find any option to import VAG samples. I'm messing with Awave Studio(kudos to ughman for suggesting that) and made a .vab out of FMOD's soundfont, although I just can't get it to work properly in any way(wrong/desynch'd instruments being played and whatnot when using the whole vab, while importing only the instruments played by the testing midi i'm using results in tick noises). The fact there seems to be no documentation available about this doesn't help either

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest