Cloudflare and https issues

Post a topic about yourself to let others know your skills, hobbies, etc.
Post Reply
User avatar
Abelliqueux
Curious PSXDEV User
Curious PSXDEV User
Posts: 18
Joined: April 29th, 2016, 7:03 am
I am a: wannabee PSX dev
Motto: nope, bicycle
PlayStation Model: 7502/5502
Want to Find: knowledge !
Looking to: learn and share
Location: PAL
Contact:

Cloudflare and https issues

Post by Abelliqueux » May 13th, 2020, 4:57 am

Hi,

I saw there were some issues with cloudflare for some other users so maybe a thread to diagnose this would be useful ?
I get a lot of cloudflare screens, sometime just refreshing the page or browsing a thread.

I also noticed that the site is sometimes messed up ( images and CSS not loading ) when not using SSL (https) , else, it is fine.
All the items on the site's menu are pointing to a non encrypted url. Maybe this would be trivial to s/http/https ? Not sure that's the crux of the issue here, but this can't hurt ! :mrgreen:
Hardware : SCPH-5502 + Psnee Attiny45, SCPH-7502 + Psnee Attiny85, Gamehunter CD version + Unirom, Gamehunter CD Lite + Unirom
https://wiki.arthus.net - https://psx.arthus.net

User avatar
Shadow
Admin / PSXDEV
Admin / PSXDEV
Posts: 2405
Joined: December 31st, 2012, 5:37 pm
PlayStation Model: H2000/5502

Re: Cloudflare and https issues

Post by Shadow » May 13th, 2020, 12:36 pm

It's the other way around. Using HTTPS (SSL) will corrupt the CSS. That's why it's failing. I'll disable the forcing of HTTPS in CloudFlare so it stops doing that. PSXDEV.NET doesn't support HTTPS yet.
Development Console: SCPH-5502 with 8MB RAM, MM3 Modchip, PAL 60 Colour Modification (for NTSC), PSIO Switch Board, DB-9 breakout headers for both RGB and Serial output and an Xplorer with CAETLA 0.34.

PlayStation Development PC: Windows 98 SE, Pentium 3 at 400MHz, 128MB SDRAM, DTL-H2000, DTL-H2010, DTL-H201A, DTL-S2020 (with 4GB SCSI-2 HDD), 21" Sony G420, CD-R burner, 3.25" and 5.25" Floppy Diskette Drives, ZIP 100 Diskette Drive and an IBM Model M keyboard.

User avatar
Abelliqueux
Curious PSXDEV User
Curious PSXDEV User
Posts: 18
Joined: April 29th, 2016, 7:03 am
I am a: wannabee PSX dev
Motto: nope, bicycle
PlayStation Model: 7502/5502
Want to Find: knowledge !
Looking to: learn and share
Location: PAL
Contact:

Re: Cloudflare and https issues

Post by Abelliqueux » May 14th, 2020, 12:26 am

Allright, seems ok now, although I feel a bit naked without SSL ;)
Thanks !
Hardware : SCPH-5502 + Psnee Attiny45, SCPH-7502 + Psnee Attiny85, Gamehunter CD version + Unirom, Gamehunter CD Lite + Unirom
https://wiki.arthus.net - https://psx.arthus.net

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest