X-Flash - Xplorer FX- Caetla stuck

General information to do with the PlayStation 1 Hardware. Including modchips, pinouts, rare or obscure development equipment, etc.
Post Reply
Curious PSXDEV User
Curious PSXDEV User
Posts: 21
Joined: December 11th, 2016, 7:47 am

X-Flash - Xplorer FX- Caetla stuck

Post by Misscelan » August 29th, 2017, 10:11 pm

Hi there,

I've recently got an Xplorer FX and wanted to install Caetla on it.
I download an X-flash cd from Orions site (http://onorisoft.free.fr/retro.htm?psx/ ... l/tuto.htm),
Booted the CD, it detected the Xplorer, I selected CAETLA037 and pressed X, then the screen stay there for 10 min, no feedback, so I reseted the PSX.
After that if I have the Xplorer FX plugged, the Playstation won´t boot, I only see a black screen.
If I remove the Xplorer and boot again the X-flash cd, and then plug the Xplorer after the X-flash menu is loaded, it freezes again and I cannot navigate the menus.

This is a 550x PAL PSX.

EDIT: The Xplorer FX is a ATMEL 29C040A (According to Xflash)

EDIT2: nevermind! Not sure what happened the first few times I tried, I tried again and it worked now :shrug

Any idea what I'm doing wrong?

User avatar
Admin / PSXDEV
Admin / PSXDEV
Posts: 2420
Joined: December 31st, 2012, 5:37 pm
PlayStation Model: H2000/5502

Re: X-Flash - Xplorer FX- Caetla stuck

Post by Shadow » August 29th, 2017, 11:22 pm

It happens sometimes. XFLASH is old software and was never fixed. Sometimes it bricks the cartridges but you can just flash some other firmware and then try again. Eventually it works :)
Development Console: SCPH-5502 with 8MB RAM, MM3 Modchip, PAL 60 Colour Modification (for NTSC), PSIO Switch Board, DB-9 breakout headers for both RGB and Serial output and an Xplorer with CAETLA 0.34.

PlayStation Development PC: Windows 98 SE, Pentium 3 at 400MHz, 128MB SDRAM, DTL-H2000, DTL-H2010, DTL-H201A, DTL-S2020 (with 4GB SCSI-2 HDD), 21" Sony G420, CD-R burner, 3.25" and 5.25" Floppy Diskette Drives, ZIP 100 Diskette Drive and an IBM Model M keyboard.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests