Silly "demo" - Where am I?

General homebrew games, programs and PlayStation PS-EXE's
Post Reply
AmiDog
Active PSXDEV User
Active PSXDEV User
Posts: 53
Joined: September 7th, 2012, 11:51 pm

Silly "demo" - Where am I?

Post by AmiDog » September 16th, 2013, 3:09 am

I hacked together a little silly "demo" yesterday, mainly to mess a little with most emulators. It requires proper emulation of CPU and GPU caches to work.

It's in the Misc section of my wiki.

User avatar
Orion_
Legendary Programmer
Legendary Programmer
Posts: 228
Joined: August 13th, 2012, 2:48 am
I am a: Programmer
PlayStation Model: Net Yaroze
Location: France
Contact:

Re: Silly "demo" - Where am I?

Post by Orion_ » September 16th, 2013, 6:26 am

In fact, you can do the same by simply using the "LoadImage" function (transfer from main ram to vram)
but this would work on emulators, whereas your demo don't.
It could be used as an "anti" emulator protection :)
Retro game development on Playstation and other consoles http://orionsoft.free.fr/

AmiDog
Active PSXDEV User
Active PSXDEV User
Posts: 53
Joined: September 7th, 2012, 11:51 pm

Re: Silly "demo" - Where am I?

Post by AmiDog » September 16th, 2013, 11:23 pm

The small square is a sprite moving around the screen. There's no magic going on in transfering the texture or clut to VRAM, it's just that after rendering the sprite the first time, I wipe the VRAM and after the demo loop has been run once, I wipe the RAM and scratchpad as well.

AmiDog
Active PSXDEV User
Active PSXDEV User
Posts: 53
Joined: September 7th, 2012, 11:51 pm

Re: Silly "demo" - Where am I?

Post by AmiDog » January 2nd, 2014, 2:23 am

Added two more silly demos to the Misc section (linked above). One which abuses the superscalar GPU design and one which setup a circular (infinite) GPU DMA chain to have a logo bouncing nicely on the screen while the CPU just sits there idling...

User avatar
inc^lightforce
Psy-Q Enthusiast
Psy-Q Enthusiast
Posts: 149
Joined: March 7th, 2013, 7:34 am
I am a: Programmer Windows+PS1, GFX Artist
PlayStation Model: Black
Skype: a5recordings
Location: Germany

Re: Silly "demo" - Where am I?

Post by inc^lightforce » January 2nd, 2014, 8:44 am

another fine BLACK SCREEN :S

AmiDog
Active PSXDEV User
Active PSXDEV User
Posts: 53
Joined: September 7th, 2012, 11:51 pm

Re: Silly "demo" - Where am I?

Post by AmiDog » January 2nd, 2014, 8:08 pm

inc^lightforce wrote:another fine BLACK SCREEN :S
On current emulators, yep, that's the most likely outcome :D They all work fine on my SCPH-7002 unit though...

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest