[DEV] - Flash Boot Rom PS1

Start a log and update it occasionally with your projects progress
User avatar
Squaresoft74
Extreme PSXDEV User
Extreme PSXDEV User
Posts: 158
Joined: January 7th, 2016, 2:55 am
PlayStation Model: SCPH-7502
Location: France
Contact:

Re: [DEV] - Flash Boot Rom PS1

Post by Squaresoft74 » August 8th, 2019, 7:14 pm

Xrider your redumped file looks completly screwed up compared to the original one, no wonder it doesn't work.
And how did this even got in ? :o
Image

Also Megavolt85 some of your BIOS files are duplicates with just different names:
SCPH5502.BIN / SCPH5552.BIN and SCPH7002.BIN / SCPH7502.BIN

You may want to check here for BIOS infos.

User avatar
Xrider
Curious PSXDEV User
Curious PSXDEV User
Posts: 20
Joined: January 4th, 2019, 2:55 am
I am a: Hardware Dev
PlayStation Model: SCPH-5502
Want to Find: Passion Shared of Dev on PSX
Contact:

Re: [DEV] - Flash Boot Rom PS1

Post by Xrider » August 8th, 2019, 9:02 pm

Yes, i have checked this last night. So crazy. Maybe an error in the software of megavolt85.
But it's ok, it's dev stuff.

I am probably the first tester
I hope megavolt85 will fix it.

megavolt85
What is PSXDEV?
What is PSXDEV?
Posts: 2
Joined: August 7th, 2019, 3:30 am

Re: [DEV] - Flash Boot Rom PS1

Post by megavolt85 » August 9th, 2019, 1:41 am

Squaresoft74 wrote:
August 8th, 2019, 7:14 pm
Also Megavolt85 some of your BIOS files are duplicates with just different names:
thank you, i'm update
Xrider wrote:
August 8th, 2019, 9:02 pm
Maybe an error in the software of megavolt85.
no, my software don't have link to psxdev :D
you make dump of your PIO CART, is not BIOS

how you write BIOS? disconnect CE from original BIOS and connect to SST39VF040 or connect SST39VF040 CE to PIO port CE?

User avatar
Xrider
Curious PSXDEV User
Curious PSXDEV User
Posts: 20
Joined: January 4th, 2019, 2:55 am
I am a: Hardware Dev
PlayStation Model: SCPH-5502
Want to Find: Passion Shared of Dev on PSX
Contact:

Re: [DEV] - Flash Boot Rom PS1

Post by Xrider » August 9th, 2019, 3:47 am

no, my software don't have link to psxdev :D
you make dump of your PIO CART, is not BIOS
I 'm sure, it's dump of the eeprom programmed with your CD.
For dump it, i have put directly the eeprom on the Minipro TL866 programmer.

But if your software have not the link to psxdev, maybe the erase fonction not work correctly ?

your software have make 30 minutes for write the eeprom for 512ko, maybe the problem of write on eeprom ?
how you write BIOS? disconnect CE from original BIOS and connect to SST39VF040 or connect SST39VF040 CE to PIO port CE?
For write on the eeprom, i have temporary connect the SST39VF040 CE to CS0 of CPU (look like action replay).
After that, i have reconnect the SST39VF040 to CS2 and original bios has been disconnected.

When i write the bios on the eeprom with me programmer, it's work when it's connected CE to CS2 and orignal bios has been disconnect.

After that, i put your CD but it's no reconnise the eeprom.
It's reconnise only when the CE is connected to CS0 (look like action replay)

i hope this information can help us

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest