Beta PS1 BIOS startup?

BIOS, Controllers, Memory Cards, Serial I/O, Parallel I/O, etc.
Post Reply
ThePSXFan
Curious PSXDEV User
Curious PSXDEV User
Posts: 11
Joined: January 28th, 2016, 9:29 am
I am a: Programmer
PlayStation Model: SCPH-102
Want to Find: Helpful advices
Looking to: Share my projects with others
Location: Krizevci, Croatia
Contact:

Beta PS1 BIOS startup?

Post by ThePSXFan » January 28th, 2016, 9:38 am

Hi forums,
I've recently started to research the PS1 and its software.
While crawling on YouTube, I found this video:
https://www.youtube.com/watch?v=vRThYTSy6s4

It looks kinda real, but the question is: Is this a startup screen from a beta console, a development console or even a retail console?
Thanks.

User avatar
Shadow
Admin / PSXDEV
Admin / PSXDEV
Posts: 2454
Joined: December 31st, 2012, 5:37 pm
PlayStation Model: H2000/5502

Re: Beta PS1 BIOS startup?

Post by Shadow » January 28th, 2016, 2:48 pm

Looks fake, but then again, that PSX logo displayed could get away with being 256 colours, which is entirely possible, but that size of image would have consumed a bit of ROM which is a huge waste. It very well could be a prototype start-up since SCEI could have been working on the 3D TMD start-up code/image.

Personally, I've never seen this BIOS, nor have I heard of such a BIOS, so I'm calling it fake until proven :)
Development Console: SCPH-5502 with 8MB RAM, MM3 Modchip, PAL 60 Colour Modification (for NTSC), PSIO Switch Board, DB-9 breakout headers for both RGB and Serial output and an Xplorer with CAETLA 0.34.

PlayStation Development PC: Windows 98 SE, Pentium 3 at 400MHz, 128MB SDRAM, DTL-H2000, DTL-H2010, DTL-H201A, DTL-S2020 (with 4GB SCSI-2 HDD), 21" Sony G420, CD-R burner, 3.25" and 5.25" Floppy Diskette Drives, ZIP 100 Diskette Drive and an IBM Model M keyboard.

Yagotzirck
Extreme PSXDEV User
Extreme PSXDEV User
Posts: 131
Joined: July 17th, 2013, 2:37 am

Re: Beta PS1 BIOS startup?

Post by Yagotzirck » January 29th, 2016, 12:14 am

I've counted a total of 6 colours and lots of subsequent identical pixels, so with something as simple as a 4 bit CLUT(theoretically even 3 would be enough but I don't think the psx supports that) and RLE encoding it might be way smaller than one might think and fit in ROM perfectly... then again there's not any link in the description of that video pointing to any reliable source so the chances of a fake are still pretty high

ThePSXFan
Curious PSXDEV User
Curious PSXDEV User
Posts: 11
Joined: January 28th, 2016, 9:29 am
I am a: Programmer
PlayStation Model: SCPH-102
Want to Find: Helpful advices
Looking to: Share my projects with others
Location: Krizevci, Croatia
Contact:

Re: Beta PS1 BIOS startup?

Post by ThePSXFan » January 29th, 2016, 2:35 am

It all looks post-edited so I think it's fake too.

User avatar
sickle
C Programming Expert
C Programming Expert
Posts: 246
Joined: July 17th, 2013, 9:32 pm
I am a: Chocolate-fueled pug fetish robot.
Location: Scotland

Re: Beta PS1 BIOS startup?

Post by sickle » January 29th, 2016, 3:48 am

Probs fake and all, but bear in mind it might be stored on the disk, as with the interlocking P&S on regular black labels.
(entirely, or in part).
I wonder if Sony had once upon a time planned to allow certain "special" bootups, containing characters from the game or other nice little touches?

ThePSXFan
Curious PSXDEV User
Curious PSXDEV User
Posts: 11
Joined: January 28th, 2016, 9:29 am
I am a: Programmer
PlayStation Model: SCPH-102
Want to Find: Helpful advices
Looking to: Share my projects with others
Location: Krizevci, Croatia
Contact:

Re: Beta PS1 BIOS startup?

Post by ThePSXFan » January 29th, 2016, 7:52 am

But again, why is there no reverb throughout the entire BIOS? Why is the fadeout slower and why is there no PS sound? I don't think the disk can contain a fullscreen image...

User avatar
sickle
C Programming Expert
C Programming Expert
Posts: 246
Joined: July 17th, 2013, 9:32 pm
I am a: Chocolate-fueled pug fetish robot.
Location: Scotland

Re: Beta PS1 BIOS startup?

Post by sickle » January 29th, 2016, 3:08 pm

Hmm, plenty of reverb but no "swoosh".
At first I was thinking that low pitched sawtooth kinda sound was still fading out, so it would be pretty hard to edit out the next bit and separate the saw from the swoosh. But I guess, sometimes when you put in a damaged disk it glitches out and takes a while, you could easily get the sound from just one bit.

In terms of raw pixels, I reckon there might have been enough space in an early bios; the actual logo would only have to be about 160x120px (320x240 * 0.5) or less (maybe like 76kb @ 4bpp, half that with super basic compression), with a teensy little bit for "TM". White poly for the background, black poly for the black square, one or two images in front.
I mean the "Sony" and "Computer Entertainment" from the first screen are viewable as raw pixels in the BIOS, and they take up a fair amount of space. (Though the diamonds are polys).

*shrug* I dunno, wouldn't surprise me if it turned out to be real or fake :p

User avatar
~PSXLoVeR95~
Active PSXDEV User
Active PSXDEV User
Posts: 48
Joined: September 18th, 2016, 1:32 am

Re: Beta PS1 BIOS startup?

Post by ~PSXLoVeR95~ » September 20th, 2016, 9:40 am

Hey guys, that video is from my channel :D.
Sorry for the confusion, also me think is a fake startup. But i noticed the quality (looks like grabbed from on VCR), no reverb and have a nice and cool PS logo transition :3.
I found this video and i uploaded on my channel, i hope is a beta startup but really hard to say ^^!
~ My PS Collection ~
2 x SCPH-1000
13 x SCPH-1002
1 x SCPH-1001
1 x SCPH-5000
1 x SCPH-5500
4 x SCPH-5502
2 x SCPH-7000
1 x SCPH-7002
1 x SCPH-7500
5 x SCPH-7502
1 x SCPH-9000
1 x SCPH-102

>>IT'S A SONY

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest