Page 1 of 1

Rumble not working

Posted: October 24th, 2015, 5:30 pm
by Killer_Code
Hello guys! I have a little problem with my psx. My cousin found a memory card that didn't have a plasic on it and he put it into the memorycard slot and now, if i plug any dualshock controller into any of the ports the controller doesn't rumble when it should. Is there anyting that i can do in this situation?

Re: Rumble not working

Posted: October 24th, 2015, 5:57 pm
by Shadow
Looks like he somehow blew the DUAL SHOCK load fuse. Odd. What model is your PSX?

Re: Rumble not working

Posted: October 24th, 2015, 6:20 pm
by Killer_Code
It's an scph-7502. It seems a little odd to me. I have no idea why the Controller port suffered damage. :shrug

Re: Rumble not working

Posted: October 24th, 2015, 6:44 pm
by cybdyn
chk power fuses))) on console's borad

Re: Rumble not working

Posted: October 24th, 2015, 6:55 pm
by Shadow
Yeah. Check FB122, FB121, FB120, FB119, FB118, FB117 and FB123. Especially check (the inductors) L104 and L106.
There are a few diodes around CN102 too, so check them also.

I assume from your wording that the PSX powers on okay, so it could very well be the controller. Try another.

Re: Rumble not working

Posted: October 24th, 2015, 7:20 pm
by Killer_Code
Yeah the console works fine but i've tried a number of controllers and none of them seemed to rumble. anyways thanks for the advice!

Re: Rumble not working

Posted: October 26th, 2015, 12:21 am
by nocash
Check if the 7.5V supply pin is still outputting 7.5V,
http://problemkaputt.de/psx-spx.htm#pin ... ycardports
sounds as if the memory card did short-cut pin 3 and 4 (7.5V and GND), thus blowing some fuse or inductor.
Should be pretty simple to find the broken component by tracing the 7.5V line with a multimeter.