Page 1 of 1

Mysterious problems with NTSC-J Um Jammer Lammy

Posted: January 18th, 2018, 11:26 am
by Octane
I own a US Playstation, a SCPH-5501 to be specific. I have an old cheat cartridge flashed with Unirom so that I can play burnt discs, everything works fine unless the game happens to have some extra copy protection. However, the game Um Jammer Lammy behaves oddly. Take note that I've only tested the Japanese release of this game. The US version is censored, and the PAL version is well, PAL when the game was developed for NTSC. Hence why I need to use the Unirom to make it work.

When I start the game, everything goes just fine. However, when I get into the actual gameplay, a buzzing noise starts to play. This only happens during actual gameplay, the game works just as intended during cutscenes, menus, and loading screens. And this happens on both burnt copies of the game and genuine copies. Nothing similar has happened with other games.

So, does anyone know what could be causing this mysterious problem?

Re: Mysterious problems with NTSC-J Um Jammer Lammy

Posted: January 19th, 2018, 1:45 am
by TriMesh
OK, do you have access to another console to test with? I've just tried this using an unmodified SCPH-5501, an old Action Replay cart flashed with UniROM v6 and a original Japanese copy of Um Jammer Lammy (SCPS-18011). There are no strange noises and it sounds identical to the same disc booted on my SCPH-7000

Re: Mysterious problems with NTSC-J Um Jammer Lammy

Posted: January 19th, 2018, 4:43 am
by Octane
TriMesh wrote:
January 19th, 2018, 1:45 am
OK, do you have access to another console to test with? I've just tried this using an unmodified SCPH-5501, an old Action Replay cart flashed with UniROM v6 and a original Japanese copy of Um Jammer Lammy (SCPS-18011). There are no strange noises and it sounds identical to the same disc booted on my SCPH-7000
I just realized that I had an unmodded Japanese PSOne lying around. The game works fine on it, so this is not really a problem anymore. But this is still a very mysterious issue.

Re: Mysterious problems with NTSC-J Um Jammer Lammy

Posted: January 19th, 2018, 12:52 pm
by TriMesh
Octane wrote:
January 19th, 2018, 4:43 am
I just realized that I had an unmodded Japanese PSOne lying around. The game works fine on it, so this is not really a problem anymore. But this is still a very mysterious issue.
It is very strange - all I can think of is that it's some sort of edge-case hardware problem like bad SPU RAM that this specific game exposes but nothing else you're tried does.

Re: Mysterious problems with NTSC-J Um Jammer Lammy

Posted: January 20th, 2018, 7:22 am
by rama3
Maybe a problem with the game code branching differently in some areas because of the regional differences (in the BIOS, for example).
All it takes is an expected SPU DMA routine delay that somehow takes more/less time on the NTSC-U machine.

Re: Mysterious problems with NTSC-J Um Jammer Lammy

Posted: January 20th, 2018, 7:39 am
by Octane
TriMesh wrote:
January 19th, 2018, 12:52 pm
Octane wrote:
January 19th, 2018, 4:43 am
I just realized that I had an unmodded Japanese PSOne lying around. The game works fine on it, so this is not really a problem anymore. But this is still a very mysterious issue.
It is very strange - all I can think of is that it's some sort of edge-case hardware problem like bad SPU RAM that this specific game exposes but nothing else you're tried does.
Yeah, that's really the most likely explanation. Isn't there any kind of service software I could run on it to check? I know there's stuff like that available for a lot of Nintendo's consoles, including one for Gameboy Advance which no emulator that exists today can fully pass.

Re: Mysterious problems with NTSC-J Um Jammer Lammy

Posted: January 20th, 2018, 2:07 pm
by TriMesh
rama3 wrote:
January 20th, 2018, 7:22 am
Maybe a problem with the game code branching differently in some areas because of the regional differences (in the BIOS, for example).
All it takes is an expected SPU DMA routine delay that somehow takes more/less time on the NTSC-U machine.
I tested it using the same configuration he did (SCPH-5501, unirom, original NTSC:J disc) - and it worked fine, which suggests that it's not a problem with the boot ROM.

I also tried in on some other consoles (SCPH-7000, SCPH-7003, SCPH-5502), and the audio was fine on those too. Note that the SCPH-7003 is actually a PU-18 machine, has the same boot ROM as the SCPH-5501 and officially supports NTSC:J discs.
Octane wrote:
January 20th, 2018, 7:39 am
Yeah, that's really the most likely explanation. Isn't there any kind of service software I could run on it to check? I know there's stuff like that available for a lot of Nintendo's consoles, including one for Gameboy Advance which no emulator that exists today can fully pass.
Not that I know of - there was apparently an "Aging test" disc that was used by Sony for in-house testing but as far as I can see it never made it out into the wild.

Re: Mysterious problems with NTSC-J Um Jammer Lammy

Posted: January 21st, 2018, 11:46 am
by Shadow
TriMesh wrote:
January 20th, 2018, 2:07 pm
I also tried in on some other consoles (SCPH-7000, SCPH-7003, SCPH-5502), and the audio was fine on those too. Note that the SCPH-7003 is actually a PU-18 machine, has the same boot ROM as the SCPH-5501 and officially supports NTSC:J discs.
Octane wrote:
January 20th, 2018, 7:39 am
Yeah, that's really the most likely explanation. Isn't there any kind of service software I could run on it to check? I know there's stuff like that available for a lot of Nintendo's consoles, including one for Gameboy Advance which no emulator that exists today can fully pass.
Not that I know of - there was apparently an "Aging test" disc that was used by Sony for in-house testing but as far as I can see it never made it out into the wild.
As far as I remember, the 'Aging Test Disc' was released here.

Re: Mysterious problems with NTSC-J Um Jammer Lammy

Posted: January 21st, 2018, 2:57 pm
by TriMesh
Shadow wrote:
January 21st, 2018, 11:46 am
As far as I remember, the 'Aging Test Disc' was released here.
Yeah, that one is the CD drive aging disc - there was a system test aging disc too, and that doesn't seem to have ever leaked. Seeing as the hardware is getting old now, maybe it would be a good idea to write some test software - testing SPU RAM is going to be annoying though, since the only way you can read it is 16 words at a time using DMA.

Re: Mysterious problems with NTSC-J Um Jammer Lammy

Posted: January 21st, 2018, 11:31 pm
by Shadow
Ah, my mistake. It's a shame that it was never released then. Coding these things up from scratch takes a lot of time and getting them to work properly without bugs is another task on top.